
AY Mail V1.4 for Windows 95/NT
Copyright © 1997-1998 Andrey Yastrebov

AY Mail is designed to send e-mail messages to multiple recipient via Internet. To use it you must have 
Windows 95 or Windows NT 4 connected to the Internet. AY Mail requires connection via WinSock. This 
means that if you can use Netscape Navigator or Microsoft Internet Explorer, you most probably can use 
AY Mail.

To send e-mail to virtually any number of recipients follow these steps:

F Write text of your message, load it from file or paste it from clipboard with Message tab.

F Compose a list of recipients with Recipients tab.

F If needed, customize headers with Headers tab.

F If needed, attach up to 20 binary files to your message with Attachments tab.

F Specify the name of the SMTP server with Options tab (needs to be done only once).

You may also save your project to file or restore it back. AY Mail automatically saves the project you work 
on and restores its state when you run it again. Additionally, you may manage multiple projects by saving 
them to files.

Note: AY Mail use for spamming is violation of user license.



Message Tab
Use Message Tab to prepare the text of your message. 

Actually, Message Tab is a fully functional Editor like Notepad (but able to handle virtually unlimited text). 
You may just type everything you want to in it, or you may load a file. Once you have the file loaded you 
can freely modify it. As with any other text editor, if you close AY Mail and have unsaved text in Message 
Tab, you will be warn about this and provided opportunity to save the text of the message. AY Mail saves 
messages just as text files, but gives them special AY Mail extension (*.aym), so if you then double-click 
this file AY Mail will be automatically launched.

You may merge the text of your message with recipient name and e-mail address given in the recipient 
list. To do so, just type <-NAME-> or <-ADDR-> in the body of your message and they will be changed to 
recipient name and e-mail address respectively. If you spelled these items correctly they will be shown in 
red to let you know that AY Mail recognized them. You may use commands from Insert menu or toolbar 
buttons to insert these automatically. This gives you great opportunity to personalize every single e-mail, 
but be advised that in this case instead of sending the message once, AY Mail will have to send every 
copy separately and it may take much more time. When inserted in message body recipient name 
appears unquoted and e-mail address appears in angle brackets.

Use Edit and Search menu as well as toolbar buttons to edit your message. Use Settings menu to change
font and behavior of the editor.
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Recipients Tab
Use Recipients Tab to compose a list of recipients. Recipients tab is a fully functional text editor, so you 
can easily change any text to match the format specified below. Moreover, you can use Reformat feature 
available in Edit menu. This will reformat nearly every text to the list of recipients as required by AY Mail. 
Just give it a try and see if it works for you. The only limitation is that it cannot be more than one recipient 
per line.

Each recipient may be represented by one line of the text. This line must contain at least valid Internet e-
mail address for recipient. AY Mail highlights all valid Internet addresses in red. Red highlighting means 
that the address looks like valid one, but it does not guarantee that delivery to that address is possible. 
For example, the address nobody@nowhere.com will be highlighted in red, because it looks correct, but it
is undeliverable just because it does not exist. Only one e-mail address is allowed per line. Any lines of 
text that do not contain e-mail address will be skipped and are considered comments. E-mail address is 
used to determine where to send message, and also it may be used to customize message body or "To:"   
header.

In addition to e-mail address you may specify additional information, which must be in the same line. This 
includes real name and encoding type. 

Real name have to be quoted like "John Doe", in which case it is highlighted in blue. Blue highlighting 
means that the name is recognized by AY Mail. There may be only one real name per line. Real name 
may be used to customize message body or "To:"    header.

Encoding type consists of the back slash followed by any word like \UUENCODE . They are highlighted in
green. Only first letter in the word matters and determines how attached files will be encoded for this 
recipient. Valid letters are:

M MIME-compliant encoding (base64)
U UUENCODE
X XXENCODE
B or H BinHex 4.0 (Macintosh encoding)

This setting overrides Default setting in Attachments Tab,which is used if you do not specify anything 
here, for this particular recipient. Using this you may send files to many people and each of them will get it
encoded in its own way. This is ignored if there is no attachments.

You can use symbols // to comment out addresses that you do not want. They will be highlighted in gray.

You may load a list of recipients from a text file, or paste it from clipboard. Or you may save it back to file. 
As with any other text editor, if you close AY Mail and have unsaved text in Recipients Tab, you will be 
warn about this and provided opportunity to save the text of the recipient list. AY Mail saves recipient lists 
just as text files, but gives them special AY Mail extension (*.ayr), so if you then double-click this file AY 
Mail will be automatically launched.

Use Edit and Search menu as well as toolbar buttons to edit your message. Use Settings menu to change
font of the editor.

Example of recipient list:

This is the list that may be used to send 
  comments about AY Mail
<AYMail@AYsoft.COM> "AY Mail Sales"  \M
"AY Mail Author"  xor@AYsoft.COM \MIME
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Headers Tab
Headers in the Internet e-mail play a role of envelope. They show an information about the message 
stored in. Actually they do not determine where to send the message to - electronic transport knows that. 
They mostly show to recipients an information about mail. Usually, e-mail clients put into headers 
information about senders, recipients etc., but here you have many recipients, so you have to decide what
your recipients will see. Your settings for headers determine only what recipient will see, not where and 
not how the mail comes. Headers may be modified during transport, so the recipient may see something 
different of what you write. AY Mail allows you to control three headers:

To: shows to whom the message is addressed. You have three options, that correspond to radio buttons 
in Headers Tab:

1. Use real recipient address in the like below:

To: <e-mail address>

2. Use real recipient address and name in the form: 

To: Quoted Name <e-mail address>

These two options are definitely the best, but this will require AY Mail to send personal message to each 
recipient instead of just sending one message to many recipients and it may take much longer. However if
you have already customized your message by merging in there recipient names or addresses, AY Mail 
will send personal message to every recipient anyway, so customization of headers will not make it less 
speedy

3. Put in there one e-mail address for all the recipients. This will allow AY Mail to send the message only 
once. It is important that the address you put in there was e-mail address, not just some text, because 
electronic transfer servers may modify it if it does not.

From: shows from whom the message is. It is highly recommended to put here your real e-mail address.
Subject: shows what is the message about.

Charset: allow you to select a character set you used to prepare your message. Improper selection of the
character set may lead to corrupted data transfer. If you are not sure what to use, try using the following 
setting: Western: iso-8859-1.
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Attachments Tab
You may put into message body only a text, but sometimes you have to transfer binary files over Internet. 
You may send them as attachments. To be inserted into the mail message, attachments have to be 
encoded. There are several encoding types and using radio buttons on attachments tab. You may vary 
them to ensure your recipients get attachments they can decode. You have the following possibilities:

1. MIME-compliant encoding (base64 method). MIME stands for Multipurpose Internet Mail Extensions. 
This is accepted as Internet standard and should be used whenever possible. However some people still 
may not be able to use MIME. In this case use other shemes.

2. UUENCODE - one of the oldest methods in the Internet. Nearly all mail clients can use it, but it is not 
always safe, so if you can use both MIME and UUENCODE, consider using MIME.

3. XXENCODE - now rather exotic method very similar to UUENCODE, but safer. Only few e-mail clients 
can use it.

4.BinHex 4.0 - this method originated from Macintosh. It is very robust and includes inherent error-
checking as well as some level of compression. Good mostly for Mac users, however many e-mail clients 
can decode it.

It may happen that different users from the recipient list need different encoding. In this case you may 
override default encoding type by specifying encoding type for some of the recipients in the recipient list. 
For the recipients for whom you do not specify anything, the default setting (selected with radio buttons) 
will be used.

You may attach up to 20 files. To attach one file press Add File button or Ins key, to remove a file from the 
list of attachments press Remove File button or Del key. Make sure the files you attached still exist at the 
time you send message.
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Options Tab
At present you need specify here your SMTP server. There are millions of SMTP servers around the 
word, but it is important to use your own - this will make transfer much more reliable. If you do not know 
your SMTP server, ask your Internet provider or look in the settings for your e-mail program - it should be 
there.

You need to specify SMTP server only once. AY Mail will remember it. However you can change it any 
time you want. If you use multiple projects then SMTP server name is stored with each project, so you 
should take care to change it for every project you use, if you change Internet provider.

You have options, that will increase connection reliability. It is recommended to use them only when you 
get connection broken errors. Changing this options will increase connection reliability. By doing that you 
sacrifice connection speed, so with a normal connection these are not needed.

You can try to do your connection better, by decreasing the size of pockets AY Mail uses. To do that, just 
slide connection track bar to the left.

You can also limit number of messages per session. The limit can change from 0 to 1000. Normally it 
should be set to 0 or left blank, which means no limitations. Using this limit makes sense only if you have 
unreliable or slow connection to your SMTP server. The less the limit the more reliable is the transfer, 
however it also decreases speed of transfer. Use this limit when you constantly get Connection broken 
error message. Try to set it first to 1000 and then gradually decrease until you get reliable transfer.
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Project Management
AY Mail stores all the settings in special project files (*.ayp extension). By default AY Mail uses project file 
DEFAULT.AYP stored in your system directory. It automatically loads it when starting and stores it when 
closing. You may use other projects. This way AY Mail will use this project, however it will return to 
working with default project if you open new project.

Project files contains all the settings - files referred to by Message and Recipients Tabs, all the settings 
from Headers Tab, default encoding and attachment list from Attachments Tab, and SMTP server name 
and message limit from Options Tab.

If you open new project, then it appears with cleared Message and Recipients Tabs, and attachment list 
from Attachments Tab, however it inherits from the last used project all the settings from Headers Tab, 
default encoding from Attachments Tab, and SMTP server name and message limit from Options Tab. 
These have to be explicitly changed as needed.

To manipulate projects use commends from File menu - New Project, Open Project, Save Project, Save 
Project As. Do not use toolbar buttons - they do not work with project files.

Main page




